Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 18, 2025 - 23:30 CEST
Scheduled
We will have a planned maintenance from 2025-10-18 23:30 to 2025-10-19 05:00 MESZ , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: Maintenance work will be performed, causing potential downtime or limited functionality from 18.10.2025 11:30 PM to 19.10.2025 05:00 AM.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Oct 16, 2025 - 10:39 CEST
This scheduled maintenance affected: Bank Connectivity (Europe).