Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2025 - 20:00 CEST
Scheduled
We will have a planned maintenance from 2025-10-17 20:00 to 2025-10-18 05:00 MESZ , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: A series of business applications and services will be unavailable during the maintenance windows on October 17, 2025, between 20:00 and 05:00, and October 19, 2025, between 20:00 and 05:00.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Oct 17, 2025 - 13:01 CEST
This scheduled maintenance affected: Bank Connectivity (Europe).