Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2026 - 00:00 CEST
Scheduled
We will have a planned maintenance from 2026-06-13 00:00 to 2026-06-13 14:00 MESZ , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: Due to maintenance at PKO Bank Polski, the PSD2 production API will be partially unavailable on 2026-06-13 from 00:00 to 14:00 local time.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Jun 12, 2026 - 10:12 CEST
This scheduled maintenance affected: Bank Connectivity (Europe).