Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 24, 2024 - 01:00 CET
Scheduled
We will have a planned maintenance from 2024-11-24 01:00 to 2024-11-24 07:00 CET , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: PSD2 APIs – Due to scheduled maintenance activity on 24th November 2024, there might be intermittent issues observed for all the PSD2 APIs from 01:00 AM CET until 07:00 AM CET. The impact should not be for more than 10 minutes during the provided window
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Nov 21, 2024 - 13:10 CET
This scheduled maintenance affected: Bank Connectivity (Europe).