Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 05, 2026 - 21:00 CEST
Scheduled
We will have a planned maintenance from 2026-05-05 21:00 to 2026-05-06 06:00 GMT+2 , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: Scheduled maintenance on ICCREA payment systems and Relax platform via CBI Globe; temporary service disruptions may occur between 2026-05-05 21:00 and 2026-05-06 06:00 local time.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Apr 29, 2026 - 16:11 CEST
This scheduled maintenance affected: Bank Connectivity (Europe).