Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2025 - 18:00 CET
Scheduled
We will have a planned maintenance from 2025-12-15 18:00 to 2025-12-15 23:00 GMT+1 , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: Mediolanum PSD2 production APIs may be temporarily unavailable on December 15 from 18:00 to 23:00 (GMT+1) due to extraordinary maintenance.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted Dec 15, 2025 - 13:19 CET
This scheduled maintenance affected: Bank Connectivity (Europe).