[TARGOBANK in DE] - Degraded performance in PIS functionality

Incident Report for Open Banking by Klarna

Resolved

This incident has been resolved.
Posted Oct 19, 2025 - 09:09 CEST

Investigating

We are currently having issues with [TARGOBANK in DE]

The issue is affecting only the Payment Initiation Service of the interface

No action is required by our customers

For more information please go to our status page and subscribe to our updates
Posted Oct 19, 2025 - 02:08 CEST
This incident affected: Bank Connectivity (Europe).