We will have a planned maintenance from 2026-05-29 15:00 to 2026-06-01 07:00 GMT+2 , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: POP Pankki is about to change its Open Banking / PSD2 service provider from Samlink to Crosskey.
Current solution in Samlink system will go offline on Friday 29th of May 4PM Finnish time. New services will open in Crosskey systems on Monday 1st of June after 8 AM Finnish time.
Existing consents will not be migrated.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted May 12, 2026 - 09:56 CEST
Scheduled
We will have a planned maintenance from 2026-05-29 15:00 to 2026-06-01 07:00 GMT+2 , due to an announced maintenance window at the bank
The maintenance is affecting all functionality of the interface
Additional information: POP Pankki is about to change its Open Banking / PSD2 service provider from Samlink to Crosskey.
Current solution in Samlink system will go offline on Friday 29th of May 4PM Finnish time. New services will open in Crosskey systems on Monday 1st of June after 8 AM Finnish time.
No action is required by our customers
For more information please go to our status page and subscribe to our updates
Posted May 11, 2026 - 13:55 CEST
This scheduled maintenance affects: Bank Connectivity (Europe).